You are not logged in.

#1 2017-01-02 13:53:33

lorenzo.lucioni
Member
15 posts

lorenzo.lucioni said:

unable to connect my Studio (6.2) to TalendForge

Tags: [bug]

Hi,
I would like to connect my Studio to my Talendforge account, but Studio stay stuck on the Exchange popup ("Connect your Studio to TalendForge, the Talend Online Community.")
My username in talendforge site contains a dot ("lorenzo.lucioni") but the "Connect your Studio..." popup does not accept dots in the username, and even the email address (in place of the username) is not accepted.

Thank you,
Lorenzo

Offline

#2 2017-01-03 03:48:00

xdshi
Talend Team


xdshi said:

Re: unable to connect my Studio (6.2) to TalendForge

Hi,
This issue comes from the Studio. The « . » is not available for the username into the Studio (as the @). Do you want to install custom component from exchange portal?
Can you log into Talend Exchange Portal from Website successfully by using your current username with a dot?
Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#3 2017-01-03 09:59:23

lorenzo.lucioni
Member
15 posts

lorenzo.lucioni said:

Re: unable to connect my Studio (6.2) to TalendForge

Hi,
Yes, I'm able to login successfully into Talend Exchange Portal website with my username containing a dot.
Can you change my username in the Exchange Portal from lorenzo.lucioni to lorenzolucioni, making me able to link the studio too?

Thank you,
Lorenzo

Offline

#4 2017-01-03 10:39:12

xdshi
Talend Team


xdshi said:

Re: unable to connect my Studio (6.2) to TalendForge

 
Hi,
Would you mind creating  a new account with a username without dot to see if it works?
 As a workaround,  can you successfully download the custom component from talend exchange portal directly and install it into studio by manual?
 
Here is a KB article about:TalendHelpCenter:Installing+a+custom+component


Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#5 2017-01-03 10:45:49

lorenzo.lucioni
Member
15 posts

lorenzo.lucioni said:

Re: unable to connect my Studio (6.2) to TalendForge

Hi Sabrina,

yes, workaround works, of course :-)
I was just willing to use the powerful connection between Studio and Talendforge, and yes, I could create a new user.


Thank you for your help,
Lorenzo

Last edited by lorenzo.lucioni (2017-01-03 10:46:56)

Offline

#6 2017-01-04 08:34:43

xdshi
Talend Team


xdshi said:

Re: unable to connect my Studio (6.2) to TalendForge

Hi,
Is the new username without dot Ok with you?
Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#7 2017-01-04 10:29:02

lorenzo.lucioni
Member
15 posts

lorenzo.lucioni said:

Re: unable to connect my Studio (6.2) to TalendForge

Hi Sabrina,
Thanks for your help. I will use workaround (manual downloading and installing components...), instead of creating a new user. I do not think to be worth to create a new user when systems are not able to manage common username format rules. 

To be true, even if you would be willing to create a new user, when I go to https://www.talendforge.org/ I see "Cloud Login" that leads me to a login page that not accept my old current login (that actually works here: https://www.talendforge.org/forum/ and here: https://exchange.talend.com/

Furthermore, I also find out this page: https://www.talendforge.org/member/profile.php, a duplication of https://www.talendforge.org/forum/profile.php?id=391592.

Too much profile/login/email-address-change/... duplicated pages for me :-) - Hope a SSO will replace everything soon.
In the meanwhile, thank you for your support. Please feel free to close the issue. 

Lorenzo

Last edited by lorenzo.lucioni (2017-01-04 10:30:41)

Offline

#8 2017-01-10 10:43:25

lorenzo.lucioni
Member
15 posts

lorenzo.lucioni said:

Re: unable to connect my Studio (6.2) to TalendForge

mmmm... Hi Sabrina,
following your kindly suggestion I created a new account, with username "lorenzolucioni" (without a dot in the middle).
I can successfully login on the website ( http://www1.talend.com/login ) but still not able to link my Talend Studio, because when I try to link it to TalendForge (username: lorenzolucioni and the right password) I get an error: (301)Moved Permanently, as you can see in the screenshot attached here.
I tried many time, restarting Talend Studio, being sure to have internet connections...
Any Suggestion?
Thank you, Lorenzo

mini_blob.png

Offline

#9 2017-01-11 17:50:58

alefebvr
Member
6 posts

alefebvr said:

Re: unable to connect my Studio (6.2) to TalendForge

Hello,
I've just tried on my Talend Studio (6.3) and have the very same (301) Moved Permanently error message.
Below the error log extract.
Best regards,
    alex
!ENTRY org.talend.platform.logging 1 0 2017-01-11 17:47:48.359
!MESSAGE 2017-01-11 17:47:48,358 INFO org.talend.commons.exception.CommonExceptionHandler - (301)Moved Permanently

!STACK 0
org.talend.commons.exception.BusinessException: (301)Moved Permanently
at org.talend.registration.register.RegisterManagement.createUser(RegisterManagement.java:359)
at org.talend.registration.wizards.register.ui.htmlcontent.TalendForgeRegistAction.run(TalendForgeRegistAction.java:120)
at org.talend.commons.ui.html.DynamicHtmlURL.runAction(DynamicHtmlURL.java:77)
at org.talend.commons.ui.html.DynamicHtmlURL.execute(DynamicHtmlURL.java:40)
at org.talend.commons.ui.html.BrowserDynamicPartLocationListener.changing(BrowserDynamicPartLocationListener.java:35)
at org.eclipse.swt.browser.WebKit.webView_decidePolicyForNavigationAction_request_frame_decisionListener(WebKit.java:1494)
at org.eclipse.swt.browser.WebKit.browserProc(WebKit.java:424)
at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
at org.eclipse.swt.widgets.Display.applicationNextEventMatchingMask(Display.java:4989)
at org.eclipse.swt.widgets.Display.applicationProc(Display.java:5367)
at org.eclipse.swt.internal.cocoa.OS.objc_msgSend(Native Method)
at org.eclipse.swt.internal.cocoa.NSApplication.nextEventMatchingMask(NSApplication.java:94)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3652)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:832)
at org.eclipse.jface.window.Window.open(Window.java:808)
at org.talend.designer.core.ui.preferences.ExchangePreferencePage$1.widgetSelected(ExchangePreferencePage.java:117)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4188)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1467)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1490)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1475)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1279)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4031)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3658)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:832)
at org.eclipse.jface.window.Window.open(Window.java:808)
at org.eclipse.ui.internal.dialogs.WorkbenchPreferenceDialog.open(WorkbenchPreferenceDialog.java:221)
at org.eclipse.ui.internal.handlers.ShowPreferencePageHandler.execute(ShowPreferencePageHandler.java:59)
at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:294)
at org.eclipse.ui.internal.handlers.E4HandlerProxy.execute(E4HandlerProxy.java:90)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:247)
at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:229)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:149)
at org.eclipse.core.commands.Command.executeWithChecks(Command.java:499)
at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:508)
at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:196)
at org.eclipse.e4.ui.workbench.renderers.swt.cocoa.CocoaUIHandler.runCommand(CocoaUIHandler.java:715)
at org.eclipse.e4.ui.workbench.renderers.swt.cocoa.CocoaUIHandler.access$6(CocoaUIHandler.java:703)
at org.eclipse.e4.ui.workbench.renderers.swt.cocoa.CocoaUIHandler$8.widgetSelected(CocoaUIHandler.java:568)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4188)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1467)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1490)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1475)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1279)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4031)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3658)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.talend.rcp.intro.Application.start(Application.java:216)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
Caused by: (301)Moved Permanently
at org.apache.axis.transport.http.HTTPSender.readFromSocket(HTTPSender.java:744)
at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:144)
at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)
at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
at org.apache.axis.client.Call.invoke(Call.java:2767)
at org.apache.axis.client.Call.invoke(Call.java:2443)
at org.apache.axis.client.Call.invoke(Call.java:2366)
at org.apache.axis.client.Call.invoke(Call.java:1812)
at org.talend.registration.register.proxy.RegisterUserBindingStub.updateUser53(RegisterUserBindingStub.java:1106)
at org.talend.registration.register.proxy.RegisterUserPortTypeProxy.updateUser53(RegisterUserPortTypeProxy.java:155)
at org.talend.registration.register.RegisterManagement.createUser(RegisterManagement.java:351)
... 76 more

Last edited by alefebvr (2017-01-11 18:10:44)

Offline

#10 2017-01-11 17:53:26

alefebvr
Member
6 posts

alefebvr said:

Re: unable to connect my Studio (6.2) to TalendForge

PS : I must have missed something, but why is this post marked as "Resolved"?

Offline

#11 2017-01-12 04:07:40

xdshi
Talend Team


xdshi said:

Re: unable to connect my Studio (6.2) to TalendForge

Hi,
We cannot repro this issue on V 6.3. Is your network Ok with you? Feel free to post your issue here.
Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#12 2017-01-12 10:13:06

alefebvr
Member
6 posts

alefebvr said:

Re: unable to connect my Studio (6.2) to TalendForge

NiHao Sabrina,
It seems that it is now working this morning after a reboot of my desktop.
I can now login into Exchange from the 6.3 Studio.
There must have been something wrong with my network indeed.
Xiexie ni for your help,
Best regards,
    alex

Offline

#13 2017-01-12 10:49:27

xdshi
Talend Team


xdshi said:

Re: unable to connect my Studio (6.2) to TalendForge

Hi,
Great this issue has been fixed. Can we consider this topic as resolved?
Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#14 2017-01-12 11:04:52

lorenzolucioni
Member
2 posts

lorenzolucioni said:

Re: unable to connect my Studio (6.2) to TalendForge

Well,
going to http://www1.talend.com/login and logging in with username "lorenzolucioni" I'm able to log-in.
When I'm trying to connect Talend Studio to Exchange, with the same username and password (of course, checked twice), now I get "Username on Password is incorrect".

Any tips? I use Talend Studio 6.2.1

Thank you,
Lorenzo

Last edited by lorenzolucioni (2017-01-12 11:05:44)

Offline

#15 2017-01-12 11:46:56

alefebvr
Member
6 posts

alefebvr said:

Re: unable to connect my Studio (6.2) to TalendForge

xdshi wrote:

Hi,
Great this issue has been fixed. Can we consider this topic as resolved?
Best regards
Sabrina

It's fine for me.
However, note that lorenzo.lucioni still has issues.

Best regards,

      alex

Offline

Board footer

Talend Contributor Agreement - Talend Website Privacy Policy