• Index
  •  » Talend Open Studio for Data Integration » Usage, Operation
  •  » Runtime-Repository not available- Error depoying Talend Job on SpagoBI

#1 2009-04-24 07:52:55

zguptn
Member
Registered: 2009-04-23
Posts: 23

Runtime-Repository not available- Error depoying Talend Job on SpagoBI

TOS Version: TOS-Win32-r22547-V3.0.4
SpagoBI Server Version: Demo-SpagoBi-2.1.0-tomcat6.0.18-003-18-2009

I am trying to deploy a Talend Job on SpagoBI Server. While deploying, I am getting a "Runtime-Repository not available" error. The error is showing up on the SpagoBI  Tomcat Console. Any ideas how to fix this or how to setup the Runtime-Repository needed by the SpagoBI Server ? Is there any setting which needs to be done on SpagoBI Server or on TOS ?

Your response is really appreciated.

The stacktrace is below:
--------------------------------------------------------------------------------------------------------------------------------
22 Apr 2009 16:01:21,593 ERROR it.eng.spagobi.utilities.engines.AbstractEngineStartServlet.handleException:110 - Service execution failed
java.lang.NullPointerException
    at it.eng.spagobi.utilities.engines.EngineStartServletIOManager.getUserIdentifier(EngineStartServletIOManager.java:117)
    at it.eng.spagobi.utilities.engines.EngineStartServletIOManager.getAuditServiceProxy(EngineStartServletIOManager.java:254)
    at it.eng.spagobi.utilities.engines.EngineStartServletIOManager.auditServiceErrorEvent(EngineStartServletIOManager.java:228)
    at it.eng.spagobi.utilities.engines.AbstractEngineStartServlet.handleException(AbstractEngineStartServlet.java:112)
    at it.eng.spagobi.utilities.engines.AbstractEngineStartServlet.handleException(AbstractEngineStartServlet.java:125)
    at it.eng.spagobi.utilities.engines.AbstractEngineStartServlet.doService(AbstractEngineStartServlet.java:95)
    at it.eng.spagobi.utilities.service.AbstractBaseServlet.service(AbstractBaseServlet.java:75)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
    at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
    at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
    at java.lang.Thread.run(Thread.java:595)
22 Apr 2009 16:41:40,968 ERROR it.eng.spagobi.utilities.engines.AbstractEngineStartServlet.handleException:110 - Service execution failed
it.eng.spagobi.utilities.engines.SpagoBIEngineException: An error occurred while executing [JobUploadService]
    at it.eng.spagobi.engines.talend.services.JobUploadService.doService(JobUploadService.java:136)
    at it.eng.spagobi.utilities.engines.AbstractEngineStartServlet.doService(AbstractEngineStartServlet.java:93)
    at it.eng.spagobi.utilities.service.AbstractBaseServlet.service(AbstractBaseServlet.java:75)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
    at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
    at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
    at java.lang.Thread.run(Thread.java:595)
Caused by: it.eng.spagobi.utilities.engines.SpagoBIEngineException: Runtime-Repository not available
    at it.eng.spagobi.engines.talend.TalendEngine.getRuntimeRepository(TalendEngine.java:65)
    at it.eng.spagobi.engines.talend.services.JobUploadService.processUploadedFile(JobUploadService.java:200)
    at it.eng.spagobi.engines.talend.services.JobUploadService.doService(JobUploadService.java:123)
    ... 15 more
--------------------------------------------------------------------------------------------------------------------------------

Offline

#2 2009-04-24 16:22:39

Fariza
Guest

Re: Runtime-Repository not available- Error depoying Talend Job on SpagoBI

Hello,
your problem is exactly as mine...did you resolve your problem, I need some help...
Best regards
Fariza

  • Index
  •  » Talend Open Studio for Data Integration » Usage, Operation
  •  » Runtime-Repository not available- Error depoying Talend Job on SpagoBI

Board footer

Powered by FluxBB