Run Talend Open Studio from Subversion sources

Even for a user, it can be very useful to run Talend Open Studio directly from its sources, connected to the Subversion official repository. It brings beta-testers the ability to check in the shortest time if a bug was correctly fixed (in their own environment, with their own data) or to see a feature as soon as it is committed.

The below steps show the path that can be used to build Talend Open Studio for Data Integration within the Eclipse IDE and also to run the application within that IDE (helpful for debugging or submitting patches). The process is very similar for the other Talend Open Studio-based products. Note: This guide is uses Linux, a Windows version is available elsewhere on the Wiki. This guide was written using the Talend Open Studio for Data Integration trunk branch (post-5.0.1) + Eclipse Indigo environment development.

Preparing Eclipse

  1. Building Talend Open Studio in Eclipse requires additional packages to be installed on top of the standard Eclipse IDE for Java EE Developers (Indigo release) distribution. While the libraries needed can be individually installed, I found I only needed to explicitly install the below three packages because of the dependencies that the three automatically bring in.
  2. From Eclipse, go to Help → Install New Software, and on the Install dialog that pops up, choose “Indigo - http://download.eclipse.org/releases/indigo” in the Work With field, and then install the following two packages under the Modeling category:
    1. ATL SDK - ATLAS Transformation Language SDK
    2. Ecore Tools SDK
  3. Then add this repository to the Work With field: http://download.eclipse.org/modeling/m2t/updates/releases/ (select the “Available Software Sites” link on the Install dialog to find this item) and install the most recent version of the following product:
    1. M2T JET SDK 1.1.1
  4. Because Talend Open Studio is very memory intensive to build, you will probably need to set higher JVM memory allocations as discussed in the Eclipse README. Doing so prevents out-of-memory errors or otherwise very slow building performance. For a Linux 64-bit desktop with 8GB of memory I placed the following settings in an eclipse.sh file:
./path/to/Eclipse/folder/eclipse -vmargs -Xmx1024M -XX:MaxPermSize=256M &

…and then run sh eclipse.sh from a terminal window to ensure Eclipse always starts up with these options.

Building Talend Open Studio

  1. Download URLs for the source code are listed here. If your goal is to debug a specific version of Talend Open Studio within Eclipse, you'll want to download a tagged version. For supplying patches, usually you will want to work with the latest unreleased code in the trunk branch. To checkout trunk, use
    svn checkout http://talendforge.org/svn/tos/trunk

    . To use a tagged version, place the tag name in the URL such as

    svn checkout http://talendforge.org/svn/tos/tags/release-5_0_1

    . The svn client will place the downloaded version(s) in separate folders named by default after the ending part of the checkout URL.

  2. Start Eclipse making sure to use the appropriate JVM arguments discussed in Step #2.
  3. From Eclipse, Go to File → Import → General → Existing projects into workspace, and select the root folder created by the svn checkout command above (“trunk”, “5_0_1”, etc.) Eclipse will display all the packages under that folder. Accept the entire list by selecting “Finish” from the Import dialog.
  4. Package compilation should be automatic and with error/warning results shown in the Eclipse Problems tab (Windows → Show View → General → Problems). There should be zero errors (if many warnings) when finished. Any compilation bugs found can be reported (optionally with patches) to the TalendForge JIRA.

Running/Debugging Talend Open Studio from within Eclipse

  1. From Eclipse, go to menu item Run → Run Configurations or Run → Debug Configurations (the latter if you expect to do code tracing within the IDE.)
  2. From either the Run or Debug Configurations dialog that comes up, choose Eclipse Application from the left-side tree and either right-click or select the New button to create a new configuration.
  3. Highlight the new configuration in the left-side tree and on the right-side Main tab, under Program To Run, choose “org.talend.rcp.branding.tos.product”.
  4. Finally, select the Run (or Debug) button to activate Talend Open Studio. Note that if you've downloaded trunk instead of a specific tagged release, errors may appear as trunk contains the most recent (unreleased) checked-in code.

Consult the Talend Open Studio forums for any questions or problems that may occur for you during this process.

 
dev/run_from_svn.txt · Last modified: 2011/12/22 07:00 by gmazza
 
 
Recent changes RSS feed Driven by DokuWiki